$re = '/([0-9]+) \(([0-9]+)\)/m';
$str = '125 (2)
102 (5)
344 (2)
264 (6)
835 (15)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);