package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]+) \(([0-9]+)\)`)
var str = `125 (2)
102 (5)
344 (2)
264 (6)
835 (15)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}