package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d[^\w\d]?){10}\d$`)
var str = `89299920290`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}