$re = '/(https?:\/\/)?(www\.)?(discord\.gg|(discordapp|discord)\.com\/invite)\/(\w+-?\w+)/i';
$str = 'discord.gg/craftserve
discord.gg/craftserve-387222965131149313
discord.com/invite/craftserve
discord.com/invite/craftserve-387222965131149313
https://discord.gg/craftserve
https://discord.gg/craftserve-387222965131149313
https://discord.com/invite/craftserve
https://discord.com/invite/craftserve-387222965131149313
https://www.discord.gg/craftserve
https://www.discord.gg/craftserve-387222965131149313
https://www.discord.com/invite/craftserve
https://www.discord.com/invite/craftserve-387222965131149313';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);