import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/)?(www\\.)?(discord\\.gg|(discordapp|discord)\\.com\\/invite)\\/(\\w+-?\\w+)";
final String string = "discord.gg/craftserve\n"
+ "discord.gg/craftserve-387222965131149313\n"
+ "discord.com/invite/craftserve\n"
+ "discord.com/invite/craftserve-387222965131149313\n\n"
+ "https://discord.gg/craftserve\n"
+ "https://discord.gg/craftserve-387222965131149313\n"
+ "https://discord.com/invite/craftserve\n"
+ "https://discord.com/invite/craftserve-387222965131149313\n\n"
+ "https://www.discord.gg/craftserve\n"
+ "https://www.discord.gg/craftserve-387222965131149313\n"
+ "https://www.discord.com/invite/craftserve\n"
+ "https://www.discord.com/invite/craftserve-387222965131149313";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}