$re = '/^(?<avg>.*)\./m';
$str = '00:00:04.32424234234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);