package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<avg>.*)\.`)
var str = `00:00:04.32424234234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}