$re = '/^[+]91[0-9]{10,10}/m';
$str = '+918516524526
+919831245787';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);