package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+]91[0-9]{10,10}`)
var str = `+918516524526
+919831245787`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}