re = /\(\d{2}\) \d{4}-\d{4}/m
str = 'João Fulano,123.456.789-00,21 de Maio de 1993,(21) 3079-9987,Rua do Ouvidor,50,20040-030,Rio de Janeiro'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end