package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(\d{2}\) \d{4}-\d{4}`)
var str = `João Fulano,123.456.789-00,21 de Maio de 1993,(21) 3079-9987,Rua do Ouvidor,50,20040-030,Rio de Janeiro`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}