re = /!\n|! +/m
str = '!book
b!ok
bo!k
book!
I love books! I read them everyday!
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end