$re = '/!\n|! +/m';
$str = '!book
b!ok
bo!k
book!
I love books! I read them everyday!
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);