import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\*.*?\\*";
final String string = "/* This is a valid comment block */\n"
+ "*/ not a valid comment block /* \n"
+ "*/ not a comment block */ ; Trying to match everything that is not a comment block entirely.\n"
+ "/* not a comment block /*\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}