package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\*.*?\*`)
var str = `/* This is a valid comment block */
*/ not a valid comment block /*
*/ not a comment block */ ; Trying to match everything that is not a comment block entirely.
/* not a comment block /*
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}