re = /[a-z_A-Z]+(?=\=)|(?<=\=)\w+(?# =后面的变量或者数字)|(?<=\=)\'.+\'|(?<=\=)\".+\"(?# =后面的字符串)/m
str = 'a=1123 b=abcABC_ANV c=\'abc_ABC ABC123\' d="abc_ABC ABC123" '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end