$re = '/[a-z_A-Z]+(?=\=)|(?<=\=)\w+(?# =后面的变量或者数字)|(?<=\=)\'.+\'|(?<=\=)\".+\"(?# =后面的字符串)/m';
$str = 'a=1123 b=abcABC_ANV c=\'abc_ABC ABC123\' d="abc_ABC ABC123" ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);