package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)<div id="testId" class="testClass">(.*?)<\/div>`)
var str = `<div id="testId" class="testClass">
<div>
<div>
contenty
</div>
<div/>
<div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}