using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div id=""testId"" class=""testClass"">(.*?)<\/div>";
string input = @"<div id=""testId"" class=""testClass"">
<div>
<div>
contenty
</div>
<div/>
<div>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}