re = /[\w*\-*]{3,}(?=[.])/
str = 'https://www.voice.mo-z1lla.co.uk:8080/folder/index.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end