$re = '/[\w*\-*]{3,}(?=[.])/';
$str = 'https://www.voice.mo-z1lla.co.uk:8080/folder/index.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);