$re = '/[[]\w+[:]\s\w+/m';
$str = '[id: string]
[bydi: number]
[any: anything]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);