package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[[]\w+[:]\s\w+`)
var str = `[id: string]
[bydi: number]
[any: anything]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}