$re = '/[\/]+$/m';
$str = 'google.com/
foo.com//
bar.com/foo/bar///
//blahfoo.comfoo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);