$re = '/[^\r\n\s]*\.(rsgsv|rsgsv\.net)($|\/[^\r\n\s]*|\s).*/m';
$str = 'bounce-mc.us17_88678681.378839-tri.susanti=balaikartini.com@mail78.suw151.rsgsv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);