using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\r\n\s]*\.(rsgsv|rsgsv\.net)($|\/[^\r\n\s]*|\s).*";
string input = @"bounce-mc.us17_88678681.378839-tri.susanti=balaikartini.com@mail78.suw151.rsgsv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}