$re = '/public (\w*?) ([A-Z])(\w*?) { get; set; }/m';
$str = ' public string TenLop { get; set; }
public int TongSoHocSinh { get; set; }
public int SoNam { get; set; }
public int SoNu { get; set; }
public int SoNhoHon18Th { get; set; }
public int SoTu18ThDen3T { get; set; }
public int SoTu3TDen4T { get; set; }
public int SoTu4TDen5T { get; set; }
public int SoLonHon5T { get; set; }
';
$subst = "\L$2\E$3: $1;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;