import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "public (\\w*?) ([A-Z])(\\w*?) \\{ get; set; \\}";
final String string = " public string TenLop { get; set; }\n"
+ " public int TongSoHocSinh { get; set; }\n"
+ " public int SoNam { get; set; }\n"
+ " public int SoNu { get; set; }\n"
+ " public int SoNhoHon18Th { get; set; }\n"
+ " public int SoTu18ThDen3T { get; set; }\n"
+ " public int SoTu3TDen4T { get; set; }\n"
+ " public int SoTu4TDen5T { get; set; }\n"
+ " public int SoLonHon5T { get; set; }\n";
final String subst = "\\L$2\\E$3: $1;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}