$re = '/xin(.*[^\s]+\s*)(?=nha)/';
$str = 'xin chao vu nha
xin bac nha';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);