using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"xin(.*[^\s]+\s*)(?=nha)";
string input = @"xin chao vu nha
xin bac nha";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}