import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((?# FIRST TYPE OF ARGS\\\n"
+ ")(?#start arg)(\"|'|`)(?#\\\n"
+ ")(?#arg)(?<arg>(?# whole repeat pattern)((?!\\3)(?(?!\\\\).|..))*)(?#\\\n"
+ ")(?#end arg)\\3(?#\\\n"
+ "))|((?# SECOND TYPE OF ARGS\\\n"
+ ")(?#start arg)(^|\\s+)(?#\\\n"
+ ")(?#arg)(?<arg_>(?#whole repeat pattern)((?!\\s|$)(?(?!\\\\).|..))+)(?#\\\n"
+ ")))(?#\\\n"
+ "skipping trailing whitespaces)(\\s|^|$)*(?=(\\s|^|$|\"|'|`))";
final String string = " arg0\\ \\ \\\\ \"arg1\\\"\\\"\" \"arg2\\\"\\\\\"\"arg3 \\\"\" 'arg4\"arg4\"' arg5 arg6 \n\n"
+ " space_bef_and_aft_even_arg0 arg1 arg2 arg3 arg4 arg5 arg6 arg7 arg8 arg9 \n"
+ " space_bef_and_aft_odd__arg0 arg1 arg2 arg3 arg4 arg5 arg6 arg7 arg8 \n"
+ "space_aft_even__________arg0 arg1 arg2 arg3 arg4 arg5 arg6 arg7 arg8 arg9 \n"
+ "space_aft_odd___________arg0 arg1 arg2 arg3 arg4 arg5 arg6 arg7 arg8 \n"
+ " space_bef_even_________arg0 arg1 arg2 arg3 arg4 arg5 arg6 arg7 arg8 arg9\n"
+ " space_bef_odd__________arg0 arg1 arg2 arg3 arg4 arg5 arg6 arg7 arg8\n"
+ "nospace_even____________arg0 arg1 arg2 arg3 arg4 arg5 arg6 arg7 arg8 arg9\n"
+ "nospace_odd_____________arg0 arg1 arg2 arg3 arg4 arg5 arg6 arg7 arg8\n\n"
+ " multispace______________arg0 arg1 arg2 arg3 arg4 \n\n\n"
+ " pbm0 pbm1 pbm2 \n"
+ "\"pbm0 pbm0\" pbm1 \n"
+ "\"pbm0 pbm0\" pbm1 \n\n"
+ " C:\\ProgramData\\Anaconda3\\python.exe C:\\ProgramData\\Anaconda3\\cwp.py C:\\ProgramData\\Anaconda3 C:\\ProgramData\\Anaconda3\\python.exe C:\\ProgramData\\Anaconda3\\Scripts\\jupyter-notebook-script.py \"%USERPROFILE%/\" \n\n"
+ " (?(?=\\2)(?(?=($|^))true|false)|false) . \n\n\n\n\n"
+ "(?:(?(?!\\3|\\\\).|(?=\\\\)..))*\n\n"
+ "((?!\\s|$)(?(?!\\\\).|..))*)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}