import Foundation
let pattern = #"itemVar":{"value":"([\s\S]*?)"}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[{"$type":"DeclareGlobalTypePropertyBlock","x":92,"y":88,"parts":{"itemVar":{"value":"GUID"},"type":{"value":"text"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"SelectedModuleGUID"},"type":{"value":"text"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"Id"},"type":{"value":"text"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"Label"},"type":{"value":"text"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"isInfiltration"},"type":{"value":"boolean"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"UnderdrainSize"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"UnderdrainInvert"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"ModuleLayoutType"},"type":{"value":"text"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"RequiredSurfaceArea"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"AcualSurfaceArea"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"DesiredWidth"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"TotalRequiredLength"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"EstimatedModuleNumber"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"ModuleWidth"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"ModuleLength"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"arrModuleLengths"},"type":{"value":"number[]"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"ModuleHeight"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"ModuleKeys"},"type":{"value":"text[]"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"extentsXMax"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"extentsXMin"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"extentsYMax"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"extentsYMin"},"type":{"value":"number"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"SystemDesignation"},"type":{"value":"text"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"isValid"},"type":{"value":"boolean"},"next":{"$type":"DeclareGlobalTypePropertyBlock","parts":{"itemVar":{"value":"hasInvalidModule"},"type":{"value":"boolean"}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)