using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"itemVar"":{""value"":""([\s\S]*?)""}";
string input = @"[{""$type"":""DeclareGlobalTypePropertyBlock"",""x"":92,""y"":88,""parts"":{""itemVar"":{""value"":""GUID""},""type"":{""value"":""text""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""SelectedModuleGUID""},""type"":{""value"":""text""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""Id""},""type"":{""value"":""text""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""Label""},""type"":{""value"":""text""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""isInfiltration""},""type"":{""value"":""boolean""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""UnderdrainSize""},""type"":{""value"":""number""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""UnderdrainInvert""},""type"":{""value"":""number""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""ModuleLayoutType""},""type"":{""value"":""text""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""RequiredSurfaceArea""},""type"":{""value"":""number""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""AcualSurfaceArea""},""type"":{""value"":""number""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""DesiredWidth""},""type"":{""value"":""number""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""TotalRequiredLength""},""type"":{""value"":""number""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""EstimatedModuleNumber""},""type"":{""value"":""number""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""ModuleWidth""},""type"":{""value"":""number""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""ModuleLength""},""type"":{""value"":""number""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""arrModuleLengths""},""type"":{""value"":""number[]""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""ModuleHeight""},""type"":{""value"":""number""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""ModuleKeys""},""type"":{""value"":""text[]""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""extentsXMax""},""type"":{""value"":""number""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""extentsXMin""},""type"":{""value"":""number""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""extentsYMax""},""type"":{""value"":""number""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""extentsYMin""},""type"":{""value"":""number""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""SystemDesignation""},""type"":{""value"":""text""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""isValid""},""type"":{""value"":""boolean""},""next"":{""$type"":""DeclareGlobalTypePropertyBlock"",""parts"":{""itemVar"":{""value"":""hasInvalidModule""},""type"":{""value"":""boolean""}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}