$re = '/((1?[0-9]{0,2}|(2[0-4][0-9])|(25[0-5]))\.){3}(1?[0-9]{0,2}|(2[0-4][0-9])|(25[0-5]))/m';
$str = 'abc192.168.87.12abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);