use strict;
my $str = 'abc192.168.87.12abc';
my $regex = qr/((1?[0-9]{0,2}|(2[0-4][0-9])|(25[0-5]))\.){3}(1?[0-9]{0,2}|(2[0-4][0-9])|(25[0-5]))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}