import Foundation
let pattern = #"^(?:[^\|]+\|){2}\K(?P<q>[^\|]*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2017-05-13|23:59:59|127.0.0.1|8080|ReGeX|http://www.example.com/index.htm|!"£$%^&*()_+|qwerty"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)