use strict;
my $str = '2017-05-13|23:59:59|127.0.0.1|8080|ReGeX|http://www.example.com/index.htm|!"£$%^&*()_+|qwerty';
my $regex = qr/^(?:[^\|]+\|){2}\K(?P<q>[^\|]*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}