use strict;
my $str = '.fixed-feedback-block {
position: fixed;
right: 0;
top: calc(50% - 33px);
cursor: pointer;
.inner {
text-indent: 10px;
}
svg {
width: 50px;
position: absolute;
top: 15px;
left: 0;
z-index: 85;
height: 20px;
}
.call-me-button {
width: 240px;
height: 50px;
display: block;
background: #f35556;
transform: translate3d(190px, 0, 0);
transition: transform 0.3s ease-out;
border: none;
box-shadow: none;
border-radius: 0;
&:hover {
transform: translate3d(0px, 0, 0)
}
}
.write-to-us-button {
width: 215px;
height: 50px;
background: #00a5b8;
float: right;
transform: translate3d(165px, 0, 0);
transition: transform 0.3s ease-out;
border: none;
box-shadow: none;
border-radius: 0;
&:hover {
transform: translate3d(0px, 0, 0)
}
}
}';
my $regex = qr/(\ {|\s+\}|:(?= )|;)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}