#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\ {|\s+\}|:(?= )|;)"
Local $sString = ".fixed-feedback-block {" & @CRLF & _
" position: fixed;" & @CRLF & _
" right: 0;" & @CRLF & _
" top: calc(50% - 33px);" & @CRLF & _
" cursor: pointer;" & @CRLF & _
" .inner {" & @CRLF & _
" text-indent: 10px;" & @CRLF & _
" }" & @CRLF & _
" svg {" & @CRLF & _
" width: 50px;" & @CRLF & _
" position: absolute;" & @CRLF & _
" top: 15px;" & @CRLF & _
" left: 0;" & @CRLF & _
" z-index: 85;" & @CRLF & _
" height: 20px;" & @CRLF & _
" }" & @CRLF & _
" .call-me-button {" & @CRLF & _
" width: 240px;" & @CRLF & _
" height: 50px;" & @CRLF & _
" display: block;" & @CRLF & _
" background: #f35556;" & @CRLF & _
" transform: translate3d(190px, 0, 0);" & @CRLF & _
" transition: transform 0.3s ease-out;" & @CRLF & _
" border: none;" & @CRLF & _
" box-shadow: none;" & @CRLF & _
" border-radius: 0;" & @CRLF & _
" &:hover {" & @CRLF & _
" transform: translate3d(0px, 0, 0)" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" .write-to-us-button {" & @CRLF & _
" width: 215px;" & @CRLF & _
" height: 50px;" & @CRLF & _
" background: #00a5b8;" & @CRLF & _
" float: right;" & @CRLF & _
" transform: translate3d(165px, 0, 0);" & @CRLF & _
" transition: transform 0.3s ease-out;" & @CRLF & _
" border: none;" & @CRLF & _
" box-shadow: none;" & @CRLF & _
" border-radius: 0;" & @CRLF & _
" &:hover {" & @CRLF & _
" transform: translate3d(0px, 0, 0)" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")