const regex = new RegExp('^(0[1-9]|[1-7][0-9]|8[0-1])(([A-PR-VYZ]{1})(?!0{4,5}$)\\d{4,5}|([A-PR-VYZ]{2})(?!0{3,4}$)\\d{3,4}|([A-PR-VYZ]{3})(?!0{2,3}$)\\d{2,3})$', 'gm')
const str = `06BM1212`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}