re = /if \((.*?)[=](.*?)\)/m
str = 'if (ddd = dd)
if (eee == ee)
if (fff === fff)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end