$re = '/if \((.*?)[=](.*?)\)/m';
$str = 'if (ddd = dd)
if (eee == ee)
if (fff === fff)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);