$re = '/(\d?\d?\d{1}\d{1})|(^[5-9])/m';
$str = '000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);