package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d?\d?\d{1}\d{1})|(^[5-9])`)
var str = `000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}