// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\+?(380 |0)(6(7|8)|9(6|7|8)) \d{3} \d{2} \d{2}").unwrap();
let string = "068 987 65 43";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}