$re = '/\+?(380 |0)(6(7|8)|9(6|7|8)) \d{3} \d{2} \d{2}/m';
$str = '068 987 65 43';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);