package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<image>[^:@]+?)(?::(?P<tag>[^@]+?))?(?:@sha256:(?P<digest>.+))?$`)
var str = `golang:1.23.0@sha256:89a1b98608f91fe47734cac497c0d7bd0c88239f90cccd00ea47057eb09604e2
golang:1.23.0
golang@sha256:89a1b98608f91fe47734cac497c0d7bd0c88239f90cccd00ea47057eb09604e2
golang
golang@sha256:232a180dbcbcfa7250917507f3827d88a9ae89bb1cdd8fe3ac4db7b764ebb25a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}