import Foundation
let pattern = #"(')([^:,]+?)(')([^:,]+?)(')(:|,)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
'statusid':'2000',
'country':'Hungary',
'pcode':'2000',
'city':'Budapest',
'street':'Route d'Arlon',
'houseno':'12',
'score':'100',
'gpslong':'6'09419',
'gpslat':'49'617081',
'a'a':'a',
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2\\'$4$5$6"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)