const regex = /(')([^:,]+?)(')([^:,]+?)(')(:|,)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\')([^:,]+?)(\')([^:,]+?)(\')(:|,)', 'g')
const str = `'statusid':'2000',
'country':'Hungary',
'pcode':'2000',
'city':'Budapest',
'street':'Route d'Arlon',
'houseno':'12',
'score':'100',
'gpslong':'6'09419',
'gpslat':'49'617081',
'a'a':'a',`;
const subst = `$1$2\\'$4$5$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);