$re = '/(?<=^|\b|(?<=\W)(?=\W))\S+?(?=$|\b|(?<=\W)(?=\W))/s';
$str = '#include <stdio.h>
int main()
{
printf("Hello, World!");
return 0;
}
public class HelloWorld {
public static void main(String[] args) {
System.out.println("Hello, World!");
}
}
MsgBox, Hello, World!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);